Message Board

Installing Honey Pots

Older Posts ]   [ Newer Posts ]
 Honeypot on Windws web server
Author: J.Fix   (27 Jan 05 10:28am)
I'm running Website Pro on W2K with both PERL and PHP installed. I installed the PERL version of the honeypot script in the correct directory but when I execute it the webserver just returns a blank page. I noticed that the PERL path on line one of the script is commented out, and it's also formatted for *nix (/usr/bin/perl). What would be the correct format for pointing to the PERL executable on my Windows server?

I tried "!d:\website\perl\perl.exe" but that generates a "500" server error.

Anyone else running the honeypot on Windows?


 Re: Honeypot on Windws web server
Author: J.Fix   (27 Jan 05 10:46am)
BTW, here's the link for the script:
 Re: Honeypot on Windws web server
Author: J.Fix   (27 Jan 05 10:55am)
OK, I answered my own question by reading the docs again (doh!). It looks like Website was properly mapping the PERL location on its own even without changing the path in the first line of the script. Since the page loads I think I've got everything installed in the right locations and mapped properly. I'm just trying to figure out why I only get a blank page when the script executes. Thanks!
 Re: Honeypot on Windws web server
Author: A.Ave Maria Co   (28 Jan 05 1:12pm)
I am having that same problem on a Windows 2000 server....

I have Perl functioning properly. All the securities enabled on files and folders. All Scripts and Executibles enabled on root and cgi-bin folders. Yet it appears when I change the mapping at the top of the .cgi file I am given two different errors.

1. The browser returns a generic 500 error ( In IE ) or "%1 is not a valid Win32 application." ( In FireFox ) when I leave the first line in the .cgi file as "/usr/bin/perl"

2. The browser's returning a CGI error however if I change it to the correct path to Perl.

I can't even get a blank page like J.Fix could. Any Ideas?
 Re: Honeypot on Windws web server
Author: S.Henningsson   (30 Aug 05 6:59pm)
I used to run OmniSecure and got the perl version running, but since I recently had to change servers (running apache 2), I've yet to get it running again. Here's my version of the problem:

I didn't even get a simple Hello World example running until I explicitly changed the path to the correct one (i.e the *nix version didn't do the trick) (using #!perl does the trick as well as the full path).

When trying the honeypot script, it gave me the same error (500 internal server error and the apache error log gave me the same response as before, i.e The system cannot find the path specified. : couldn't spawn child process: C:/!HTTPD/helloworld.cgi

If I change the path in the script to, say #!perl then the server doesn't have a problem, but I get the validation error instead -_-;

Is there something I've missed that will enable me to run any perl script without changing that path or am I out of luck? I've looked for help with the apache configuration but haven't had any real luck so far...
 Re: Honeypot on Windws web server
Author: S.Henningsson   (30 Aug 05 7:16pm)
Doh! Silly me.. Got it working :) Had gone to bed and suddenly remembered something I'd heard.. Not to try and activate it through localhost/! So I went to the domain I had set up and voila, it worked.

Sometimes I do the silliest things!

do not follow this link

Privacy Policy | Terms of Use | About Project Honey Pot | FAQ | Cloudflare Site Protection | Contact Us

Copyright © 2004–18, Unspam Technologies, Inc. All rights reserved.

contact | wiki | email