Message Board

Installing Honey Pots

Older Posts ]   [ Newer Posts ]
 Validation fails with IPv6 client
Author: S.Smeenk   (21 May 07 3:21pm)
Hi.

I'm trying to set up honeypots and contribute to this project, but setting up honeypots seemed to constantly fail.

Investigation shows that you try to send the server reported IP-address of the server itself in the 'svip'-key, but in my case, this is an IPv6 address. Your check probably looks up the v4 address for my server and compares that to the reported address -> Fail.

I've disabled my IPv6 connectivity for a sec, and lo-and behold, i have successfully installed my honeypot! :)

You might wanna rewrite that check a bit :)

Regards,
Sander.
 
 Re: Validation fails with IPv6 client
Author: M.Prince   (21 May 07 8:22pm)
Yep. We do not currently support IPv6. We will at some point, but, as you can imagine, it will require a major restructuring of our systems.
 
 Re: Validation fails with IPv6 client
Author: S.Smeenk   (24 May 07 4:18am)
I'm sorry, but why does this require a major restructuring of the systems?

I assume you use some DNS lookup library to check the A label of the reported server hostname against the reported server IP. Wouldn't it be as easy to do something like this pseudocode:

if ($reported_ipaddr =~ /:/) { # aparently v6
$dns_addr = lookup($reported_hostname, 'AAAA');
}
if ($dns_addr !~ $reported_ipaddr) { fail(); }

But then again, i don't know what else you check :)

It would be nice if you could fix this, as IPv6 is becoming more and more 'common' on the net!

Thanks anyways.
 
 Re: Validation fails with IPv6 client
Author: R.Odom   (20 Oct 07 12:32pm)
I'll second that IPv6 request! Spent a while puzzling over the "A validation error occurred" error until I came across this thread. At the very least, a quick fix would be to detect an IPv6 address and say "Sorry, IPv6 not supported yet - please access via IPv4". That would save some head-scratching!

Regards,

Russ

Post Edited (20 Oct 07 2:15pm)
 
 Re: Validation fails with IPv6 client
Author: R.Odom   (30 Oct 08 6:05pm)
OK, just over a year later, installing a new honeypot and I'd forgotten about this! Much head-scratching ensued again until a quick Google turned up this answer :-(

If you're using Firefox, a quick way to turn off IPv6 is to type "about:config" in your address bar, find the value "network.dns.disableIPv6" and set it to "true". Visit your honeypot again, and it'll now validate OK. Set the config value back to "false" once you've validated OK.

And, if I may, I'd now like to second the request for IPv6 support once again!

Regards,

Russ
 
 Re: Validation fails with IPv6 client
Author: M.Sommer   (29 Mar 09 6:14am)
I tried that. doesn't work for me :-( I still get the validation error. btw i'm running lighttpd on a linux system, is that a problem?
 
 Re: Validation fails with IPv6 client
Author: C.Dearborn   (29 Dec 11 10:24pm)
Still broken :(
This is very bad in todays age. I'm getting quite a few hosts from IPv6 now and my entire network is dual stack.




do not follow this link

Privacy Policy | Terms of Use | About Project Honey Pot | FAQ | Cloudflare Site Protection | Contact Us

Copyright © 2004–17, Unspam Technologies, Inc. All rights reserved.

contact | wiki | email