Message Board

Installing Honey Pots

Older Posts ]   [ Newer Posts ]
 Validation errors (using PHP and NGINX)
Author: N.Daugherty   (25 Jun 12 12:19pm)
Hi there,

I'm wondering if someone could help me out. I've tried installing several honeypots now, and I can't get them to validate when I visit the URL.

All I get is an error message that says...

>> A validation error occurred. If this problem persists, you will need to generate a new script.

I've tried several new scripts and followed the instructions exactly. No dice. What now? Anyone been able to resolve this issue? Does the honey pot work with NGINX?
 
 Re: Validation errors (using PHP and NGINX)
Author: T.Barrow   (10 Jul 13 12:21pm)
Hi,

Did you ever get a fix for this? I have had the same problem using ColdFusion. Have tried putting the code in different places, generating new honeypots, etc.

Thanks,

Ting
 
 Re: Validation errors (using PHP and NGINX)
Author: H.User2584   (23 Oct 13 9:55am)
if you're trying to get to your honeypot on an ipv6 address, you'll see this. Had me confused for a whiiiile. They should probably add something about this to the FAQ/install...
 
 Re: Validation errors (using PHP and NGINX)
Author: P.Skovgaard   (12 Feb 14 3:31pm)
Hi

Still can't activate... Checked all the things above.
Using NGINX I still get "A validation error occurred. If this problem persists, you will need...". I have checket permissions etc on PHP script, still no luck. Any idea what's wrong?

Post Edited (12 Feb 14 3:43pm)
 
 Re: Validation errors (using PHP and NGINX)
Author: T.Garrison3   (3 Aug 14 1:28am)
It has to do with how fast cgi gets environment variables. On my debian system it was easy to fix by changing /etc/nginx/fastcgi_params

fastcgi_param SERVER_NAME $server_name;

and replacing $server_name with the server host name (no quotes were needed.)

Hope that helps someone out there :)
 
 Re: Validation errors (using PHP and NGINX)
Author: H.Retzgen   (16 Sep 14 2:17am)
I also get the error (Apache 2) and I suspect its an IPv6 Issue. I have changed the network precendence setting so that IPv4 should be preffered but still no luck. I recently installed PHP 5.6.0. Are there any know problems with that?

Post Edited (16 Sep 14 2:28am)
 
 Re: Validation errors (using PHP and NGINX)
Author: J.Allen15   (10 Dec 14 5:42am)
I have tried several times to install and have got tyhe same error every time.
Config:
debian jessie
apache2 2.4.10
libapache2-mod-PhP-mod5 - 5.6.2
PHP% - 5.6.2

Network
IPv4 + IPv6

DNS - bind9 + DNSSEC + DANE

any other info let me know.
 
 Re: Validation errors (using PHP and NGINX)
Author: A.Brand   (9 Mar 15 12:45pm)
I always get this message too. I have two different domains and with one domain the honeypot works perfectly. But in the other domain I always get this error.

Works perfectly on http://www.olexx-webdeveloper.de (Apache/2.2.8 (Linux/SUSE)) - there the [SERVER_ADDR] is 195.78.76.197.
The domain where the honeypot does not work is http://www.wohligdampfen.de (Apache/2.2.29 (Unix)) - there is NO [SERVER_ADDR].

Is this maybe the reason for the error?

I really want to install a honeypot but it doesn't work.
 
 Re: Validation errors (using PHP and NGINX)
Author: C.Falconer   (27 Apr 15 4:27pm)
wohligdampfen.de has address 81.169.145.158
wohligdampfen.de has IPv6 address 2a01:238:20a:202:1158::

So the browser is using IPv6 and the script can't verify itself. Force it to use IPv4 by putting your v4 address in rather than the hostname.
 
 Re: Validation errors (using PHP and NGINX)
Author: R.Bormann   (7 Jul 15 1:29pm)
Hello, I see this post goes back a while. I am getting the same error "A validation error occurred. If this problem persists, you will need to generate a new script."

I am using NGINX with proxy pass. Could that be an issue? Is there anywhere I can look to see more detail on the error?

Any help would be great.
 
 Re: Validation errors (using PHP and NGINX)
Author: L.Horror   (13 Jul 15 11:40pm)
i'd say it's definitely an ipv6 problem.
i was trying to validate a honey pot while i was using an ipv6 proxy. constant errors.
the minute i switched back to an ipv4 proxy it validated first time. no change needed on the server side...just my browser.
 
 Re: Validation errors (using PHP and NGINX)
Author: IpCOP6   (6 Dec 15 12:29pm)
It is just problem with IPv6. When you try to activate, just disable your IPv6 connection for a while and try to activate it via IPv4 connection. It works for me! :)
 
 Re: Validation errors (using PHP and NGINX)
Author: M.Davids   (3 Mar 16 2:00pm)
Still no fix, I assume?
 
 Re: Validation errors (using PHP and NGINX)
Author: C.Dearborn   (14 May 16 4:15pm)
If you have IPv6 on both the server, and the host running the web browser, just disable IPv6 on the host with the web browser while you visit the page. They should still make it work with IPv6 though.
 
 Re: Validation errors (using PHP and NGINX)
Author: H.Bachhal   (29 Jun 16 11:54am)
fastcgi_param SERVER_NAME $server_name;

and replacing $server_name with the server host name (no quotes were needed.)
This Works

Post Edited (29 Jun 16 11:55am)
 
 Re: Validation errors (using PHP and NGINX)
Author: E.Cote2   (19 Nov 16 7:51pm)
Would be helpful if the script would support IPv6....

 
 Re: Validation errors (using PHP and NGINX)
Author: S.Friedrich   (31 May 17 11:45am)
If the honeypot wouldn't validate when using IPv6, does the honeypot work correctly after validating it via IPv4?

Or will it ignore every bot using IPv6?



do not follow this link

Privacy Policy | Terms of Use | About Project Honey Pot | FAQ | Cloudflare Site Protection | Contact Us

Copyright © 2004–17, Unspam Technologies, Inc. All rights reserved.

contact | wiki | email