Message Board

Installing Honey Pots

Older Posts ]   [ Newer Posts ]
 Installing problems with php
Author: S.Henningsson   (2 Feb 05 4:07pm)
When I try to load the script I get the following:

A validation error occured. If this problem persists, you will need to generate a new script.
PHP Notice: Undefined index: email in C:\!HTTPD\helloworld.php on line 249 PHP Notice: Undefined index: emailmethod in C:\!HTTPD\helloworld.php on line 250 PHP Warning: Cannot modify header information - headers already sent by (output started at C:\!HTTPD\helloworld.php:3) in C:\!HTTPD\helloworld.php on line 253

I'm running OmniSecure with PHP 5.0.3 on a Win2k machine. I tried setting PHP with backwardscompability, enabling various things that were disabled in the recomended .ini file but nothing works.

I did add one empty line to the script since, for some reason, the combination of PHP 5 and OmniSecure (not sure which does this to the other) drops the first line so I have to add one empty line every file. No t much of a problem though. Other PHP scripts I've written myself seem to work but those aren't very advanced as I'm a PHP newbie..

I'm running this at forcefed.bounceme.net on a machine that, for the moment at least, won't be up all the time.. It'll be up for aother couple of hours after this though..

Staffan
 
 Re: Installing problems with php
Author: L.Holloway   (2 Feb 05 6:38pm)
Adding an empty line should screw up the PHP Pot; those PHP Notices although annoying won't effect the operation of the script.

The 'PHP Warning: Cannot modify header information - headers already sent by (output started at C:\!HTTPD\helloworld.php:3)' message seems a bit odd to me; maybe thats because an extra line was added. In any case it doesn't seem like that effecting your scripts processing. (Its contacting the server just fine and getting a result back.)

The root of the problem is that your webserver/environment is returning odd server values:

SCRIPT_NAME : C:!HTTPDhelloworld.php
PHP_SELF : C:!HTTPDhelloworld.php
(odd that its not including the slashes)
REQUEST_URI comes up blank
The IP is reported as 127.0.0.1 -- but that could be because your accessing your script from the machine itself. We wont accept / record IPs like localhost, 192.168.X, since these addresses

Unfortunately there is not much we can do on the server end to help you out. I tried to reproduce some of the errors but it looks like forcefed.bouncenet.net isnt up right now. We certainly appreciate the attempt!

We do support perl, asp, python and cold fusion is those are options for you.
 
 Re: Installing problems with php
Author: D.Taylor   (3 Feb 05 12:30am)
To get rid of the "PHP Warning: Cannot modify header information - headers already sent..." create a .htaccess file in your root directory, or add the following line it if the file is already there:

PHP_FLAG output_buffering on
 
 Re: Installing problems with php
Author: S.Henningsson   (5 Feb 05 1:21pm)
I did try accessing it through the forcefed.bounceme.net address and I set the webserver address to that as well (in the webserver config), but this didn't do anything to solve the problem. I can't create that .htaccess file.. Windows just tells me I need to have a filename which isn't very strange since those . files are for *nix system IIRC :)

Anyway, I added a file named htaccess anyway and added that line just to try that and then tried accessing the page from another computer and I got the same errors.

Maybe I should look into finding a way around that weird problem with needing to add one empty line to every page or try using another script or even another webserver...
 
 Re: Installing problems with php
Author: P.Blackburn   (7 Feb 05 9:23am)
I get essentially the same errors - the line numbers are 2 less is the only difference - and have not changed the file at all. The index errors appear to be caused by the lines:

$email = $settings["email"];
$emailmethod = $settings["emailmethod"];

and the header error results from the earlier error messages being output before the HTML header line.

I have tried this on two machines: one running PHP 4.2.3 under Win2k, and one running PHP 4.3.6 on WinXP Home SP2. As far as I can tell, the $settings array is filled in remotely in some way, but I can't tell whether this is working.

I'm trying to set this script up in www.pbcomps.co.uk which points at http://80.3.249.31/public/pbcomps.
 
 Re: Installing problems with php
Author: J.Turkia   (3 Nov 05 9:58am)
There is a major flaw in the PHP script for us developers using maximum error reporting. Simply put, the makers of the script were too lazy to test it properly.

As the PHP-script cannot be edited (the fix would be really simple). I ended up putting this Apache .htaccess-file into the directory of my pot:
php_value error_reporting E_ERROR

Now it works as expected.



do not follow this link

Privacy Policy | Terms of Use | About Project Honey Pot | FAQ | Cloudflare Site Protection | Contact Us

Copyright © 2004–17, Unspam Technologies, Inc. All rights reserved.

contact | wiki | email